Can't install OCaml 4.09, even though it's in Nixpkgs

Solved: I needed to install ocaml as ocamlPackages_latest.ocaml

I can’t seem to install OCaml 4.09, even though it’s in nixpkgs here. I’m subscribed to both nixos-19.09 and nixos-unstable channels, so I’m not sure why I can’t find it. Any ideas? Thanks!

There are some explanations in the wiki too: https://nixos.wiki/wiki/OCaml#Specific_version_of_the_OCaml_compiler