Can't share screen in Slack using Wayland

I’m running Slack 4.25.1 on unstable. I can share some apps but cannot share fullscreen (it shows a black screen with cursor moving around).

Tried the steps from this page: Slack - NixOS Wiki … Wondering if that page is out of date?

Anyway I tried NIXOS_OZONE_WL=1 slack and Slack crashes:

Initializing local storage instance
(electron) Sending uncompressed crash reports is deprecated and will be removed in a future version of Electron. Set { compress: true } to opt-in to the new behavior. Crash reports will be uploaded gzipped, which most crash reporting servers support.
[21075:0523/] Passthrough is not supported, GL is egl, ANGLE is 
[21075:0523/] InitializeSandbox() called with multiple threads in process gpu-process.
[05/23/22, 10:14:29:740] info: 
║      Slack 4.25.1, linux 5.15.39 on x64      ║
[05/23/22, 10:14:29:740] info: Configured logger via 
  "enableConsoleTransport": true,
  "identifierOverride": "webapp-service-worker-console",
  "shouldUseNewBackend": false,
  "loggerInstanceCount": 2
[05/23/22, 10:14:29:740] info: Predefined values for process 
  "NODE_ENV": "production",
  "platform": "linux",
  "type": "browser",
  "timeZone": "America/New_York",
  "PACKAGE_MANIFEST.productName": "Slack",
  "PACKAGE_MANIFEST.version": "4.25.1",
  "PACKAGE_MANIFEST.commit": "f7abf75",
[21030:0523/] Gtk: gtk_widget_add_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed
[21030:0523/] Gtk: gtk_widget_add_accelerator: assertion 'GTK_IS_ACCEL_GROUP (accel_group)' failed
Segmentation fault (core dumped)

Any ideas?

  1. List item
1 Like

you didn’t specify which wayland. wlroots-based or gnome/kde something mayble?

Thanks @tgunnoe I’m running GNOME 42.1 .

Hey there @tgunnoe any ideas or thoughts?

Same for me but I’m not a nixos user.