Can't uninstall Microsoft-Edge-Dev - Please help

I have installed microsoft edge using nix-env and I can’t uninstall it
I did “nix-env --uninstall microsoft-edge-dev-122.0.2353.0”
Command completed no error however it is still there!!

Also “nix-env -qi” nothing is showing, however freaking EDGE is still installed

I tried:
“nix-env -e microsoft-edge-dev” → warning: selector ‘microsoft-edge-dev’ matched no installed derivations
“nix-env --uninstall microsoft-edge-dev*” → warning: selector ‘microsoft-edge-dev*’ matched no installed derivations
which microsoft-edge →
which: no microsoft-edge in (/run/wrappers/bin:/home/marcelb/.nix-profile/bin:/nix/profile/bin:/home/marcelb/.local/state/nix/profile/bin:/etc/profiles/per-user/marcelb/bin:/nix/var/nix/profiles/default/bin:/run/current-system/sw/bin)

I tried: sudo nix-delete -r microsoft-edge → nix-delete: command not found

nix-env -e '.* ’ → warning: selector '.* ’ matched no installed derivations

I even tried last command as root but and same message “warning: selector ‘.*’ matched no installed derivations”

This freaking ms-edge still installed

There is nothing in configuration.nix, I dont use flakes nor home-manager.

How can I remove this freaking browser???


What do you consider “still there”?

What does nix-env -q show you?

[marcelb@Trico:~]$ nix-env -q


The freaking MS-EDGE is still installed, I am writing this on microsoft-edge…

Configuration.nix has nothing mentioning microsoft-edge

environment.systemPackages = with pkgs; [ bottles btrfs-progs btop ccache cachix digikam ethtool freetype fwupd floorp git glxinfo hddtemp hdparm hplip hwinfo kio-admin libreoffice libva-utils lm_sensors nix-index nix-tree neofetch pciutils qbittorrent-qt5 smartmontools usbutils vlc wget usbutils vulkan-tools yakuake
# nix-software-center

How do you start it? This looks like KDE, which again has a lazy launcher, that relies on cached entries.

Try a reboot to force a recache.

Then edge should also vanish from the launcher.

Thanks for your support, however I have reboot many times and still there

The .xdesktop is pointing to

and if I try to install a newer version (123.xx.xx.xx) to try and uninstall it after, I can’t have access to the new version, only to the 122.xx.xx.xx installed

it is really freaky…

Thank you!

you gave me the breadcrumbs to find a solution

I did search for force redo cache nixos and it pointed me to a post back in 2022 with the same issue.

solution that works:

nix-store --query --referrers /nix/store/....-source | xargs nix-store --delete

It is finally gone!!

1 Like