Can't update google chrome

I have google chrome installed via configuration.nix and chrome says it is out of date and can’t update, and I need to reinstall. I tried removing it from my config and rebuilding, and adding it again, and rebuilding, but that didn’t help.
I rebuild by flakes: sudo nixos-rebuild switch --flake ~/nixos#nixos

I also tried sudo nix-channel --update but I understand that this command is not needed on flakes.

Be aware that there should be a flake.lock in your flakes directory, that pins the nixpkgs ref to a specific commit.
To update that you need to run nix flake update (to update all flake inputs).
After that you should rebuild your system.
That should update chromium to some version around 124.

You will not be able to update chrome via it’s internal updater as this is contrary the idea how nix stores it’s content (and also contrary a package manager on traditional lines work), so using the distros functionality (for nixos that’s nix) is the way to go.


Good piece of info! I didn’t even know that…