CLion + Copilot on NixOS

I know this have been answered several times, but none of them really helped me.

I’m a complete newbie to Nix and NixOS so I don’t know exactly how to manipulate the config files etc.

SO my problem is that I installed CLion, installed the Copilot plugin within the IDE and it’s impossible to connect to my GH account (see photo)

I also tried adding this line in my package list in the configuration.nix :
(pkgs.jetbrains.plugins.addPlugins pkgs.jetbrains.clion ["github-copilot"])
But this time, when I open the Copilot chat, this loads forever :

Thanks in advance for your help!

Since you tried to install the plugin from the IDE before adding that line, you might need to delete theese files as the Jetbrains Tools - NixOS Wiki suggests:

Note that Jetbrains IDEs tend to manage their configuration and plugins statefully. For example, if you have previously attempted to install Copilot through the IDE’s plugin manager, you may need to delete the IDE’s state in as described in the JetBrains documentation.

I just changed my config file to remove clion from my package list, rebuilt, deleted all these files, added the lines for clion + copilot to my config again, re-rebuilt.
When launching CLion, Copilot wasn’t even pre-installed and when installing it, the same problem happened, “failed to initiate the github login process”

This might be a networking/connectivity problem if you’re behind a proxy or a VPN. For that, I recommend following the steps in ⚡️ Initial HTTP proxy support for Copilot · community · Discussion #29127 · GitHub.

As suggested there, one quick way to check if you can connect to copilot services is to run:

curl --verbose

Aside from this, I don’t really know what might be causing this.

I can connect to copilot services, it’s not the problem.

Thanks for the help anyway

1 Like