Compiling intel-oneapi-compilers


I’m trying to install an intel oneapi compiler but I am haveing difficulties.

I if I follow the official instructions, I receiver an error message

/home/maxwell/Desktop/oneapi/l_BaseKit_p_2024.0.1.46/bootstrapper: cannot execute: required file not found

If I run that binary /home/maxwell/Desktop/oneapi/l_BaseKit_p_2024.0.1.46/bootstrapper I get the same error. It has no --help flag.

This process works easily on other systems but not on nix.

(1) Does anyone know what might be different about nix that is causing this error.

(2) Does anyone know how to get intel compilers on nix.

Thank you

I’m wondering if I should install in a docker container or virtual machine, with the same instruction set. Hopefully, the compiled artifact is portable within the same instruction set. It’s a very hacky approach. But being able to install stuff is very important to me and this is a total deal breaker if I can’t

I managed to make oneapi work in FHS environment, see here.
I use it to compile VASP, and successfully run some small VASP jobs for test, see here.
But big jobs seems to be always crash when using VASP compiled by oneapi, still do not know why. VASP compiled with GNU compilers always run well, but could only reach less than half of the performance comparing with intel version, in the small test job.


On nixos, you may need to configured both

  • envfs to allow executing FHS based programs on a non-FHS system
  • nix-ld to run unpatched dynamic binaries on NixOS.