Connect Monero wallet with Trezor safe 3

Hello everyone,
I am using monero wallet on nixos and i wanted to create new monero hw wallet with Trezor safe 3.
There is tutorial on trezor website. But when i select trezor version and click create wallet, it fails because Trezor was not found.

services.trezord.enable = true;
services.udev.packages = with pkgs; [ trezor-udev-rules ];
environment.systemPackages = with pkgs; [

I also tried cli version of monero wallet, with same result.
I normally use trezor suite and it works.
Thanks everyone for your help

Hello :wave:

Please provide more info - which version of NixOS and trezor-suite are you using? What exactly the error message is saying? (Also providing a link for the tutorial you mentioned would be nice :slight_smile:) Btw. have you checked Nixpkgs issue tracker for similar issues, e.g. , maybe there is something relevant?

Thanks for reply. I solved it, by installing feather instead of monero gui/cli. But i didnt solved the issue itself.

You should open an issue in Nixpkgs on github and ping me and prusnak.
I maintain the monero packages, but I don’t have a trezor so I can’t really test it.
I just noticed that trezor support may have been accidentally disabled at build time. I’ll look into this as soon as I have time.