Containers not surviving browser

I’ve tried several different types of containers with no luck. I’m perfectly find continuing with docker-compose in Nixos as I’d like to get off my Debian box. But running that appeared to work, then it’d fail as none of the ports were actually working. Then I attempted a more nixified way from github but it too appeared to create then not be accessible via localhost:port.

I took this to nextcloud which Nix has it packaged nicely. Nextcloud - NixOS Wiki the default configuration didn’t work. Nothing ever seems to get through the invisible firewall, which i’ve tried disabling as well adding the ports.

Not sure what commands to pull out to dig deeper at what’s going on.

I did discover something strange with the architecture listing as i868. When I run the command without -d (detached?) it seems to make mention of it. This is def an x86_64 VM so not sure how to change this on Nix.

I may have messed up. Further digging shows my minimal nix ISO is i686 architecture. Any fixing this?

Sorry, but I cannot visualize it properly.

Is this?

edit in PlantUML