Could not load the Qt platform plugin "xcb" in "" even though it was found

Hi there,
I am experiencing this issue with a number of apps, but mainly in Distrobox, and Genymotion.

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Aborted (core dumped)

I experience this issue in NixOS trying to use Genymotion, and I experience this in most applications inside of Distrobox. I have seen it in other applications but I cannot remember which ones.
Anyone have any ideas about what this issue is and how it can be solved? What I would need to do to investigate?

Not sure if you solved this yet, by my fix to this was to write a small wrapper around the application to make changes to the environment variables:

   #Simple wrapper for Chitubox 
   cd /opt/Chitubox

Thank you so much! I had given up completely on this.
I opened a terminal and added the 2 unset commands and start genymotion and it worked!
Can I ask how I would go about creating a permanent fix for this? Where would I add the unset commands?