Davinci Resolve Studio install Issues

Hello, I am new to nixos and am trying to install Davinci Resolve Studio. version
I am using Nixos 23.11 and have declared the resolve package from nixos packages and rebuilt .
Install looked to go well.
I don’ have a launcher which I expected. When I run davinci-resolve-studio in konsole i get the following error message… phil is my user name
bwrap: Can’t find source path /home/phil/.local/share/DaVinciResolve/license: No such file or directory
I have installed studio in the main nixos config file and also re installed nixos and created home manager and installed it there to but no luck.
I have nvidia driver and cuda both working properly.
I also installed the free version which worked perfectly after creating a .desktop file so I can launch it.
I have searched for an executable file to launch the activation window to no avail. So I cannot use my activation key anywhere.
Any help would be brilliant. I just hope I am not making a bad error somewhere.

You have this but not sure if it can work with NixOS.

I guess the error says what the problem is.

Can’t find source path /home/phil/.local/share/DaVinciResolve/license: No such file or directory`

Can you try creating a directory in that place?

mkdir -p ~/.local/share/DaVinciResolve/license

I think he just has a license code, not a license file.

Yes, but if I understand this correctly (I don’t use the paid version), DaVinci Resolve Studio might want to make such a file in said place.

This github comment linked below is where my idea originated. The paid studio version was added to the derivation quite recently it seems:


Clearly this one won’t work. Executing bin file in NixOS does not work.

Thanks for your replies.
I tried the command nothing appeared to happen.
If I use dolphin file manager to go into the nix store and find the Davinci resolve Studio package when I open it it has a file named .license not license
I guess this could be the answer.
I cannot rename it or create a new file due to it being read only.
I guess the issue could be the activation window needs write permissions to allow the activation key to be inserted then registered. Only a noobs guess!
But thanks must go to also for the people who packaged resolve studio at least I can try and get it to work.

As you said, NixOS is read only. I don’t know/think if write permission has any sens with this distro.

I tried the command nothing appeared to happen.

The command run in your shell / terminal should create a directory. I would hope that this is enough to run Davinci Resolve Studio after that without getting the error from the beginning.

But thanks must go to also for the people who packaged resolve studio at least I can try and get it to work.

Yeah, kudos to them. Packaging Davinci Resolve even non-studio was quite a collective effort if I recall correctly.

mkdir -p ~/.local/share/DaVinciResolve/license

This is the correct action. It’s a quirk of various things and due to a limitation of the current buildFhsEnv that someday I may get around to addressing. Can read more details in the commit.

after creating a .desktop file so I can launch it.

Manual creation of the desktop file will no longer be needed with davinci-resolve: fix desktop item by amarshall · Pull Request #278164 · NixOS/nixpkgs · GitHub

To any of you Studio users: Could you verify that PR works and add a review?

Just opened PR to remove the need to manually create the license dir davinci-resolve-studio: Automatically create license dir by amarshall · Pull Request #278738 · NixOS/nixpkgs · GitHub

Unfortunately, though, it depends on a change not in 23.11, so cannot yet be backported.

1 Like

Thanks to everyone who has helped me with this issue!
I am just very grateful for all of your efforts on this and all the devs that work on nix os. I did try to get it working by searching all over for the folders etc but gave up for now.
I have installed the free version of Davinci Resolve and must say it works perfectly.
I must also say that other than having to create the .desktop file so I can launch it, the installation is really easy on nix os, much easier than on ubuntu based distros and the like.
Nix os is a bit of a learning curve for me but I am so happy I switched to it.

Hello again, as a newcomer to NixOS I thought I would do another install and keep it simple by just using the configuration.nix file for everything. So decided to try installing the resolve studio version again. It built as expected and I made sure to run…
mkdir -p ~/.local/share/DaVinciResolve/license
prior to running studio for the first time.
I then launched resolve studio from the terminal and the studio activation window appeared. I activated my license and everything works perfectly.
I then created a launcher for studio which rather than trying to add to the studio folder which is read only I simply placed the .file in my home directory. I then dragged it to my bottom panel (KDE Plasma) and now all is good.
I just thought I would let anyone else who might be struggling with resolve studio how I did it.
Obviously I couldn’t have succeeded without help, so thank you again everyone.
Regards Phil

I’m facing the same issue with the Studio version, but I can’t find a solution.

After I create the missing directory (mkdir -p ~/.local/share/DaVinciResolve/license), and start davinci-resolve-studio, I get the window to enter my license key, then after clicking on Activate, after some time (10-20s I’d say), I get an error that says “There was an error when attempting to perform the activation.”

With strace, I can see file written to the license directory, named “Do-NOT-Touch-Anything-in-This-RLM-Directory”, then files whose names are made of “1” and “l”. Then they get cleaned.

I have another installation on a different separate machine (a MacBook) on which it works well, even if I deactivate the license, then activate it back. So the license is fine (and entering a wrong one report a different error) and I’m not blacklisted. I have one activation left, and all my attempts so far doesn’t seem to count (otherwise I would have reached the limit long ago).

I contacted the BlackMagic support about this error, and they said: “As you are using Linux, the activation process may be associated to not having the correct permissions set for the licensing folder, depending upon the distribution or user configuration this can cause DaVinci Resolve to not activate.”

However, even with full permission on the license directory (chmod 777) I still get the same error.

Anyone else observe the same behavior?

Hello, since I got mine licensed it has been working very well and was updated without any issue recently.

From previous experience of installing studio on various distros, (arch, rhel, debian, kubuntu etc)
I have had to contact BMD support several times to get the license sorted out having seen the same activation error message. Even when I have deactivated properly before changing distros it would then not license on the new install. I asked them if l was licensing the distro or the machine hardware, which I think could be the issue but they never answered me. Could be they think I am trying to hack the license or something. I have also had a drive fail with the activation running and then reinstalled without issue when I should theoretically have had no activation’s left. So it makes me think it is more a licensing issue than a NixOS one but I am obviously no expert.
They can reset your license which is what has sorted things out for me. This would obviously deactivate the license on a second licensed machine so that would need licensing again.
This might not be of much help to you as you obviously understand more about Nix OS than me but thought I would reply. Phil

Update from my previous message: trying to install davinci-resolve-studio in a fresh NixOS VM did work well (after manually creating the missing directory). I have now reached the activation limit, but I asked the BlackMagic support to reset it, so it should be fine. So something is wrong with my setup. I will try to figure which element of my NixOS configuration is causing issues. I will keep you updated, if I’m not alone in this situation.

Follow up: it works now! I commented out most of my configuration.nix, switched to it, and then I was able to activate the license successfully. But I don’t know which part of the configuration was causing issue unfortunately.

Nothing on a license.
My attempts at getting Studio to run result in this error -

❯ davinci-resolve-studio 
ActCCMessage Already in Table: Code= c005, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c006, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= c007, Mode= 13, Level=  1, CmdKey= -1, Option= 0
ActCCMessage Already in Table: Code= 2282, Mode=  0, Level=  0, CmdKey= 8, Option= 0
PnlMsgActionStringAdapter Already in Table: Code= 615e, Mode=  0, Level=  0, CmdKey= -1, Option= 0
log4cxx: No appender could be found for logger (BtCommon).
log4cxx: Please initialize the log4cxx system properly. Linux/Clang x86_64
Main thread starts: 5BA13100
log4cxx: setFile(./logs/rollinglog.txt,true) call failed.
log4cxx: IO Exception : status code = 30
0x7f245ba13100 | Undefined            | INFO  | 2024-01-27 08:59:46,945 | --------------------------------------------------------------------------------
log4cxx: No output stream or file set for the appender named [RollLogAppender].
0x7f245ba13100 | Undefined            | INFO  | 2024-01-27 08:59:46,945 | Loaded log config from /home/martin/.local/share/DaVinciResolve/configs/log-conf.xml
0x7f245ba13100 | Undefined            | INFO  | 2024-01-27 08:59:46,945 | --------------------------------------------------------------------------------

Does anyone have any suggestions?
Thanks to all