Different binary of chromium runed by hyprland

I am using hyprland, and in it’s config I set key binding to run chromium:

bind = $mainMod, G, exec, chromium

But, I found that it runs different chromium binary which differs from my chromium which i configured in /etc/nixos/configuration …

so then I run it from console it’s ok - it use correct binary like this :

which chromium

but then I run it with keybinding from config above I found that is runs something like this:

ls -l /proc/15808/exe

This is not chromium generated from nixos config for user1…

Why this happens? why I have this additional binary?

How can I run generated by system chromium (/etc/profiles/per-user/user1/bin/chromium) with hyprland keybinding ?

ps. I try to set in config directly “/etc/profiles/per-user/se7en/bin/chromium " but no effect it again run " /nix/store/1ldcf59h42lvnkmzj2n2ynh674ns7r58-chromium-unwrapped-125.0.6422.141/libexec/chromium/chromium” instead

The chromium at the path /etc/profiles/per-user/se7en/bin/chromium is a symlink to a different path in your Nix store. You should check if it links to the same binary in the Nix store.

I found that binary same and running command same, but Profile Path is different, processes runs with same users, why different profiles paths specified?