Disable shutdown splash screen

Since a few week I have a delay at shutdown (after installing/removing k3s).
I would like to have more insight about it (on ArchLinux I usually have a line mentioning the service having a time out), but I have a splash screen, while my configuration does not specify neither boot.loader.grub.splashImage no boot.loader.grub.splashMode.
Is there a way to drop it?

I remember having a splash screen a few years ago (maybe Linux Mint or Fedora) where I could toggle the splash screen and the shutdown messages by pressing (I think it was) Escape. Maybe this is true for yours as well.

Regarding the options, I don’t have ever configured a splash screen with NixOS and I do not have one. So I guess it should not be there if you didn’t configure it… Did you ever activate it or was it there from the beginning?

Maybe there is some global state in your /etc that causes the splash screen to still appear after you removed the option to enable it. In this case you can try the NIXOS_LUSTRATE part from Installing from another Linux distribution. But be aware that this will remove program settings saved in /etc.

Essentially what you do is to create the file /etc/NIXOS_LUSTRATE and then add each path that you don’t want to be removed to it, each path in a separate line.

You can for example decide that you want to keep your docker containers and /etc/secrets by adding



Even though /etc/nixos and /home should not be deleted even if you do not exclude anything, I’d still add them, just to be sure. You might also want to keep the /root directory, if you have something like an SSH key for your root user.

But don’t be too afraid, the files will not simply be removed. They are moved to /old-root so you can restore them using mv /old-root/* /old-root/.* /.

After you added everything you want to keep, you have to reboot. During the next boot, NixOS will move all the other files, that are not managed by NixOS to /old-root and you get a somewhat “reinstalled” system.

When I did this a few days ago, I noticed that my audio settings (default in-/output etc.) and a few other (minor) things have been reset but overall there was not too much I had to re-configure.

Maybe this can help remove the splash screen and with a bit of luck, it might also fix your delay at shutdown :sweat_smile:

The on-shutdown splash screen is most likely boot.plymouth.enable. You should indeed be able to temporarily hide it with escape, which will show you the terminal “behind” it (and you can turn it back on with escape too).

The grub splashscreen is different, I forgot exactly what it shows. It may just be the boot selection screen, I think you can apply pretty background pictures to it.