Discord Voice is Cracking. Using pipewire

I came here as a last resort. I been trying for the last couple days. Trying to see if I can figure out the issue. I never done anything with audio equipment like this before on linux. I been guessing on how to configure my config. My conclusion so far is that pipewire is bug. But it could be because I don’t understand how to configure these sort of things.

He part of my configuration.nix file: nixpkgs.config = { allowUnfree = true;};#discordnixpkgs.overlays = - Pastebin.com
I’m trying to grab discord-ptb from the main site. Don’t think that working. Since I seen a few of the issue been fix using ptb version.
I even tried:
NIX_PATH=nixpkgs=https://github.com/NixOS/nixpkgs/archive/master.tar.gz nix-shell -p discord-ptb --run Discord

I’m still running into the same Voice cracking with my microphone when testing in Voice & Video in setting.

I have tested to make sure my mic is working in arecord and aplay. I have notice that arecord only work when setting to -c 2.

I been trying to get pipewire to used pulseaudio setting load-module module-udev-detect tsched = 0. Don’t think that working. pipewire.conf show it differently.

          "args": {
            "load-module module-udev-detect tsched": "0"
          "path": "pactl"

and when I try doing it from command line. I get this:

pactl load-module module-udev-detect tsched = 0
Failure: No such entity

Then I try setting microphone to mono. But Discord can’t pick up any sound from it.

I’m really lost in what todo next.
Here packages I have installed

environment.systemPackages = with pkgs; [
  wget nano vim commonsCompress mpd mpc_cli cantata libreoffice-fresh krita
  maim lm_sensors neofetch dmidecode inxi gitAndTools.gitFull chromium
  kitty acpi howl hikari wofi waybar xorg.xdpyinfo glxinfo htop grim
  ps_mem nyxt qutebrowser brave slurp nnn firefox-wayland pciutils
  usbutils qjackctl alsa-utils pulseaudioFull
#  teamspeak_client
  ripgrep clang fd emacs-all-the-icons-fonts xonsh python39Packages.pip
  (emacs.override { withGTK2 = false; withGTK3 = true; })
### Steam
vulkan-tools vulkan-loader vulkan-headers vulkan-extension-layer
### Discord
# audio
lame mpg123 libmad flac vorbis-tools alsa-lib libogg ffmpeg libvorbis

pw-cli dump: id: 0 permissions: rwxm type: PipeWire:Interface:Core/3 cookie: 409903512 - Pastebin.com

I really don’t know what to do next on how to fix this sort of thing. I tried everything I can wrap my head around. But nothing is working so far. Any lead will be wonderful.
Thank you.

  • system: "x86_64-linux"
  • host os: Linux 5.15.54-xanmod1-tt, NixOS, 22.11 (Raccoon), 22.11pre399062.3a11db5f408
  • multi-user?: yes
  • sandbox: yes
  • version: nix-env (Nix) 2.10.3
  • channels(root): "nixos"
  • nixpkgs: /nix/var/nix/profiles/per-user/root/channels/nixos