Discourse has stopped working when visited using qutebrowser

I’d love it if whoever maintains this instance would back discourse off to the version we had until today. If not then I won’t be using it much any more.


Reading that now, it looks grumpy! I am grateful to whoever’s running this, and am only grumpy with discourse, not with you.


Did you check upstream for an issue? discourse is an open source project.

1 Like

I’m running this instance and I’m a qutebrowser user, too. Sucks, but I also understand that Discourse doesn’t want to support old rendering engines and we cannot stay on an outdated version of Discourse any longer.

Have you tried the Qt6 version of qutebrowser which uses a more modern Chromium version?



what does not work ?

I am posting this message from qutebrowser qt6 right now … and don’t see any difference from using with brave for example.

1 Like

I updated to latest nixos unstable and still get this error trying to access the nixos discourse with qutebrowser.

Does anyone know where the announcement is or justification for this change is from Discourse?

It’s quite infuriating.

I would find it myself but I don’t get the search feature on discourse.org with my unsupported browser.

Edit: Okay… it’s still a bit bothersome but the fix was relatively easy:

qutebrowser = {
      enable = true;
-      package = pkgs.qutebrowser;
+      package = pkgs.qutebrowser-qt6;