Discourse NixOS module planned version packaging policy change

When we started packaging the Discourse forum NixOS module, we packaged the Stable branch. Now, we are planning to switch to packaging the Beta branch for a variety of reasons outlined in this issue.

For security reasons, we will also need to backport the Beta branch releases to the NixOS 21.05 and 21.11 branches. If you are using Discourse on NixOS and keeping your machines up to date, you should expect to be upgraded to the Beta branch. Luckily, I’m not aware of any recent upgrade issues, so it should be smooth.

2 Likes
Hosted by Flying Circus.