Do not allow reboot in Plasma for unprivileged user - change Polkit configuration


I noticed that when I’m logged into KDE Plasma as unprivileged user (not in wheel group) I can type poweroff or reboot without sudo into terminal and it shuts down / reboots my laptop. And I don’t like the configuration since I rebooted my laptop by mistake twice in the last week :wink: . I thought I’m rebooting a server over SSH not realizing that I jumped of SSH :wink: .

The only way this can be configured is Polkit and it’s probably some new Plasma configuration / NixOS specific configuration since a year back I was on Debian on an older version of Plasma 5 and reboot wouldn’t work without sudo.

Do you have any idea how to disable this Polkit configuration? I looked into /etc/polkit-1/rules.d/ but I don’t see there anything else than 10-nixos.rules file which doesn’t specify anything around reboots.

Thank you.