Duplicate entries in KDE System Settings after upgrading to 19.09

NixOS newbie (but long-time Linux user). First time posting here, so please let me know what if any additional information might be helpful!

After upgrading from 19.03 to 19.09 the other night, I noticed numerous duplicate entries in the KDE System Settings application. In particular:

  • The Breeze and Breeze Dark (but not Oxygen) Plasma desktop themes are duplicated in “Look and Feel”.
  • The Breeze and Plastik (but not Oxygen) KWin decorations are duplicated in “Window Decorations”.
  • Most, but not all, services listed in “Background Services” are duplicated.

This doesn’t seem to be causing any trouble (selecting a duplicate Plasma theme or Kwin decoration results in the correct style being applied, services all appear to work fine), but definitely looks odd, and makes me worried that I may be missing a bigger issue.

Things I’ve tried:

  • Searching through /run/current-system to see if there were any duplicate symlinks (there are none that I can find).
  • Deleting ~/.cache (no change, though i’d been having some issue with Akonadi that cleared up after doing this).
  • Deleting ~/.config/startupconfigfiles, which seemed to include a lot of duplicative paths pointing into the Nix store (no change, and the file was regenerated with the duplicate paths still there).

Interestingly, there’s a passing comment in GitHub from a few years ago that references what appears to be the same issue after upgrading KDE, but no resolution or follow-up about this particular issue occurred then, and the author never brought it back up.

Has anyone else run into this issue with KDE on NixOS? If so, do you know what causes it, and were you able to resolve it?

2 Likes

try executing kbuildsycoca5

I also have the same issue (even after cleanup), but only on GTK themes section
EDIT: nevermind I also still have everywhere, I was just not looking…

To prevent regeneration:

  1. Switch to the console: Ctrl-Alt-F2 (or 3,4,…)
  2. login and stop the display-manager service
  3. then remove the files you’d like to remove while plasma is not running (otherwise it’ll always regenerate)

This is especially problematic when you want to remove some hardcoded Kwin extension keyboard shortcuts etc. so stopping the process would guarantee it.

After the cleanup (switching to your normal user if you’re root) running kbuildsycoca5 (maybe with --noincremental, that’s I always use) should tidy things up.

I feel like UI got a bit faster after cleanup though, krunner was sluggish after first upgrade for some reason.

No dice, unfortunately…

  1. kbuildsycoca5 has no effect.
  2. kbuildsycoca5 --noincremental has no effect.
  3. Logging out, switching to a different TTY, stopping the display service (and then any services associated with my user for good measure), and deleting ~/.cache has no effect (kbuildsycoca5 seems to be run automatically when logging back into KDE from SDDM). (I should have been clearer, but this was also more-or-less what I initially tried.)

After each run, I rebooted just to be 100% sure.

Is there anywhere else KDE might be storing caches or old paths?

I’m also having issues with KDE after a 19.09 upgrade. I can’t seem to change settings. For instance, when I try to change the monitor setup, click apply resets the settings to whatever it was before.

1 Like

Sadly it doesn’t seem to be the problem of the caches. I’ve created a new user and logged in to plasma session, there were double themes.

Maybe a search path is given twice, not sure.

Here is the bug report: https://github.com/NixOS/nixpkgs/issues/71023

I can confirm this bug in NixOS 19.09 as well. Additionally, I’m also experiencing the same issue as @andgate