Enabling X11 still results in Wayland

Not sure why, and I’ve read a few other posts here, but I have (seemingly) everything I should to enable X11 but for some reason I’m still on Wayland.

# Enable the X11 windowing system.
  services.xserver.enable = true;

  # Enable the GNOME Desktop Environment.
  services.xserver.displayManager.gdm.enable = true;
  services.xserver.desktopManager.gnome.enable = true;

  # Configure keymap in X11
  services.xserver = {
    layout = "us";
    xkbVariant = "";

  xdg = {
    portal = {
      enable = true;


OS: NixOS 22.11.1895.ab1254087f4 (Raccoon) x86_64
Host: HP 8A78
Kernel: 5.15.89
Uptime: 32 mins
Packages: 1002 (nix-system)
Shell: zsh 5.9
Resolution: 1920x1080, 2560x1080
DE: GNOME 43.2 (Wayland)
WM: Mutter
WM Theme: Adwaita
Theme: Adwaita [GTK2/3]
Icons: Reversal-dark [GTK2/3]
Terminal: alacritty
Terminal Font: JetBrains Mono
CPU: AMD Ryzen 7 PRO 5850U with Radeon Graphics (16) @ 1.900GHz
GPU: AMD ATI Cezanne
Memory: 3226MiB / 15327MiB

services.xserver.enable makes X server available (among other things) but the choice of what display server is actually used is up to the display server (GDM in your case). Since you are enabling the GNOME module so you will have gnome and gnome-xorg sessions and GDM will default to the former.

You can change the session in the cog wheel menu on the login screen. Or declaratively preselecting it using services.xserver.displayManager.defaultSession option.

Thanks for the help (: