ENVFS not working

Hi all

Just upgraded to 23.11 and now i get this when i want to execute any bas script like i did in 23.05 before i added envfs:

  services = {
    envfs = {
      enable = true;

errors on 23.11:

bash: /run/current-system/sw/bin/gitup: /usr/bin/env: bad interpreter: Transport endpoint is not connected

i removed envfs.nix and its working, is this right?

1 Like

I’m having the same issue when I enable services.envfs on 23.11. More specifically, it seems that /bin/ is not mounted properly, as lsing the directory produces the same error, “Transport endpoint is not connected”.

I bit the bullet and did a fresh install of 2311.

The very 1st thing i did was a sudo nixos-rebuild switch --upgrade before i added any custom configs

Straight after that i add the services.envfs.enable = true; and then aa rebuild and tested a simple bash scriot with a bin/bash shebang and worked no issues.

After that i put in my custom snippets and carried on as usual. I have no idea to why it worked now and not from the upgrade

Some mounting issues caused by new kernel versions might be fixed by [release-23.11] envfs: stability backports by Mic92 · Pull Request #281615 · NixOS/nixpkgs · GitHub