Error: hash mismatch in fixed-output derivation ''

error: hash mismatch in fixed-output derivation ‘/nix/store/’:
specified: sha256-kiPErzrr5Ke77Zq9mxY7A6GzS4VfvCtKDRtwasCaWhY=
got: sha256-qNUVrWxgp55at+E9f26AQnKyIU//W73Ugsl5CIIMPQ0=

perhaps the cuda download from nvidia was altered?

What do I do to finish my installation here?

turns out it solved itself awhile later. Not sure if there was an actual update or not?

weird, reinstalling after repartitioning on the same machine I get the same error, and again, it seems to clear up on it’s own after attempting again?!? I don’t really like inconsistent errors, makes me want to test the underlying disks for errors… or memory… my stomach feels upset all of a sudden…

I just had the same problem installing fluent-bit for the last couple of days, and this morning it installed just fine.

I see this commit from 3 days ago changed the hash of the fluent-bit package: fluent-bit: update source hash · NixOS/nixpkgs@c45ceda · GitHub

So my question is - how could the hash change without any other change to the nix package?

1 Like

The src of that package (and most packages that use fetchFromGitHub) specify a rev. There’s nothing stopping upstream from force-pushing to that rev, changing its hash. Someone with access to Hydra can probably access the cached copy of the previous version of the source and check what changes.

1 Like

Sooo, this one is the run-file based installer which is something like 4 or 5GB in size and which we don’t support anymore in 24.05/unstable: it’s been renamed into cudaPackages.cudatoolkit-legacy-runfile or something. The reason the FOD sometimes works and sometimes gives the mismatch is likely because nvidia’s servers aren’t reliable enough to transfer the entire 5GB blob. I think we’ve seen this before. This shall remain a mystery because there’s no reason to use the run-file based installation anymore, use normal cudaPackages instead