Error when building with custom nixpkgs path

so I’ve been on the stable branch of NixOS for … forever and tried to migrate from i3 to sway this weekend, with good results and a few rough edges that might be fixable by updating to the unstable channel plus some patches.
My problem is that I can’t get it to build this way:

>git checkout origin/nixos-unstable
>sudo nixos-rebuild boot -I nixpkgs=/home/jonas/git/nixpkgs
building '/nix/store/fivgcnmgkdpvkr61dncgfdk75867q1n5-bootstrap-tools.drv'...
Unpacking the bootstrap tools...
: not line 5: 
builder for '/nix/store/fivgcnmgkdpvkr61dncgfdk75867q1n5-bootstrap-tools.drv' failed with exit code 127

Setting the channel and using that worked fine in the past (though currently cifs-tools can’t be built when it succeeds on Hydra … but that is probably a separate issue).
Does anyone have an idea what the problem might be?

As it turns out, I had not searched enough: fails with exit code 127 because of dos line endings · Issue #97040 · NixOS/nixpkgs · GitHub
For work I had in my .gitconfig core.autocrlf=true. After changing it to input and cloning nixpkgs again, I now get the same cifs-tools error as on the unstable channel and that seems to be related to a custom build flag …

Huh, might be worth looking into if we can make the build (more) independent of your .gitconfig though…

Im the one who wrote this issue and solution and would agree with that. :smiley: Also glad that I helped someone!