Evolution font changes with 23.11

It’s fairly specific, but maybe someone has an idea. I just upgrade from 23.05 to 23.11. The upgrade went almost as smooth as usual, but something changed to the visual appearance of Evolution, a gtk3 application:


The UI font and icons changed. It used to look like on the right, but now looks on the left. I don’t mind the icon change, if that’s intentional by upstream, but the font looks smaller or thinner.

Is that normal, or did I do something wrong?

(My setup is plain X11 with XMonad as the window manager, not full Gnome, and I understand that that is fairly niche, but maybe someone has seen the same change and can comment.)

I get the same changes no matter whether I run the evolution binary form the old or new system, so it doesn’t seem to depend on the actual evolution or gtk versions.

Comparing the strace -e file I find that it tires to access these directories, which actually differ:

~ $ ls /nix/var/nix/profiles/system-37{4,5}-link/sw/share/icons/Adwaita/16x16
actions  apps  categories  devices  emblems  emotes  legacy  mimetypes  places  status  ui

devices  emblems  mimetypes  places

There was an upgrade of the theme, it seems:

~ $ ls -l /nix/var/nix/profiles/system-37{4,5}-link/sw/share/icons/Adwaita
lrwxrwxrwx 1 root root 87  1. Jan 1970  /nix/var/nix/profiles/system-374-link/sw/share/icons/Adwaita -> /nix/store/hmz72yq3xn397r6irkvw660ccjkd76pw-adwaita-icon-theme-44.0/share/icons/Adwaita
lrwxrwxrwx 1 root root 87  1. Jan 1970  /nix/var/nix/profiles/system-375-link/sw/share/icons/Adwaita -> /nix/store/9lw0v9gx0s0qyzgn0jdabgch3lmkrivx-adwaita-icon-theme-45.0/share/icons/Adwaita

The upstream NEWS don’t mention that stuff got dropped, but “New build system“ sounds suspicious…

Indeed, downgrading to 23.05’s gnome.adwaita-icon-theme at least gives me the icons back. Maybe a simple bug somewhere. Reported at


The icon change was intentional by Evolution, you can change them back to non-symbolic under PreferencesAppearance.

The font looks like font aliasing difference, we changed the defaults in fontconfig, though in your case it looks like it went the opposite direction (from grayscale to rgba) edit: I misread the direction. Try checking the settings:

$ nix-shell -I "nixpkgs=$HOME/Projects/nixpkgs" -p glib gsettings-desktop-schemas --run 'XDG_DATA_DIRS=$GSETTINGS_SCHEMAS_PATH gsettings get org.gnome.desktop.interface font-antialiasing'

Thanks a lot for the help.

I found the setting in evolution, it was set to “Autodetect” before, and it seems the changes to adwaita-icon-them made the auto-detection go wrong maybe? In any case, setting this to “Prefer symbolic” fixed it.

As for the font, the command you gave also returns greyscale, both in the old and the new configuration. Also, changing that key using dconf-editor does not seem to have an effect, while changing the key org.gnome.desktop.interface font-name affects some of the fonts shown by Evolution.


fonts.fontconfig.subpixel.rgba = "rgb"

seems to affect parts of the Evolution view, e.g. the email header; the same parts that the dconf font-name setting affects, but not the UI fonts. Odd.