Failed to start pipewire-media-session.service

I recently installed NixOS with sway, that I used before on Fedora.
I followed this page of the wiki to configure it and everything worked properly
except on thing : pipewire video capture.
I tried those commands (from the wiki) :

dbus-update-activation-environment --systemd WAYLAND_DISPLAY XDG_CURRENT_DESKTOP=sway
systemctl --user stop pipewire pipewire-media-session xdg-desktop-portal xdg-desktop-portal-wlr
systemctl --user start pipewire pipewire-media-session xdg-desktop-portal xdg-desktop-portal-wlr

And it gave me that ouput :

Failed to stop pipewire-media-session.service: Unit pipewire-media-session.service not loaded.
Warning: Stopping pipewire.service, but it can still be activated by:
Failed to start pipewire-media-session.service: Unit pipewire-media-session.service not found.

I tried video capture in both obs studio and firefox and it didnt work.

If someone has any idea, thank you for your answer.

pipewire-media-session is the deprecated session manager. These days you should enable services.pipewire.wireplumber.enable and make sure that is started instead.

I believe it’s socket activated too, so shouldn’t need to be explicitly started with systemctl, but I’m not sure. I may just have it as part of