Fix steam black library/store

This morning, the steam client updates. Now all html windows (library/store/community) are just black.

Inside the client settings, I select “Delete web browser cache” and “Delete all browser cookies”.
I removed everything:

rm -rf .cache/fontconfig/  
rm -rf ~/.local/share/Steam 
rm -rf ~/.steam  

Nothing helps.

I tried x11 and Wayland. I tried my laptop, which does not have an Nvidia card. The same problem there. I can see my library in “big picture mode”, but I cannot start games from there.

Any suggestions?


Found an issue at github: Steam beta 2021-09-07: steamwebhelper cannot find LIBTHAI_0.1.25 on NixOS · Issue #462 · ValveSoftware/steam-runtime · GitHub
although I have the same issue with the non-beta version.

Nixos 21.05, steam(not beta version).
I hit that bug too.
There’s also a pending pull-request related here steamPackages.fhs: load vendored steam libraries by jonringer · Pull Request #120829 · NixOS/nixpkgs · GitHub
I can start some games from the command-line while steam is launched :
steam-run /mnt/disk/jeux/SteamLibrary/steamapps/common/Terraria/Terraria

I tested the PR, and it does not fix this issue. I tested it with the beta and non-beta version of steam.

steamwebhelper.log still says

1 Steam runtime environment up-to-date!
2 Warning: An unexpected error occurred while executing “/sbin/ldconfig -XNv”, the exit status was 127
3 ./steamwebhelper: /home/me/.local/share/Steam/ubuntu12_64/steam-runtime-heavy/usr/lib/x86_64-linux-gnu/ version `LIBTHAI_0.1.25’ not found (required by /lib64/

I guess this is now tracked in Steam: embeddedd browser not working with latest update · Issue #137279 · NixOS/nixpkgs · GitHub


I’m finding that big picture mode still works fine after the steam update. Using that might be a temporary workaround for anyone experiencing this issue.

Can confirm that Big Picture mode still works for me too.

The small Mode also works as a workaround.


I did not even know small mode existed. Very nice indeed!

For those who also did not know it existed, you can go to “view” > “small mode”.

1 Like

This will also help temporarily by adding the full set of libraries steam is expecting for the UI. (only pango is presently in the FHS environment)

  nixpkgs.config.packageOverrides = pkgs: {
    steam = pkgs.steam.override {
      extraPkgs = pkgs: with pkgs; [

I hit this problem too. Lutris is also a workaround, it can launch your Steam games.

Install and open Lutris, select the Sources → Steam category on the left menu, click the Refresh icon beside it, and then you should see a list of your Steam games. You may need to select each one and click Install at the bottom, but it won’t reinstall them, will just configure them in Lutris. Then you can launch them from Lutris, and things like the Steam Overlay still work with no problems.

My Steam and Lutris config:

  #enable Steam:
  programs.steam.enable = true;

  environment.systemPackages = with pkgs; [
    # WINE 

    # Lutris
    #lutris-unwrapped  # (not needed)

    # Extra dependencies

That doesn’t solve the problem of adding new games to your Steam Library, but at least makes it easy to play the current ones till this bug is fixed.

For people finding this still, it seems to be fixed now, I removed the fix and updated my packages with sudo nixos-rebuild switch --upgrade and it works again.