Flatpak not following GTK theme

I’ve recently installed NixOS on a brand new PC. I have been having quite a few struggles with theming my desktop. I at first struggled a lot trying to get basic apps to theme, but I fixed that by using themechanger. This created ~/.config/gtk-3.0, ~/.config/gtk-4.0 configuration files and set them properly. This works fine for regular installed apps, however for flatpaks it seems to not follow my theme at all.

I am running Hyprland with the following portals:

  • xdg-document-portal
  • xdg-destkop-portal-gtk
  • xdg-destkop-portal-wlr

Using Door Knocker gives me two warnings about not finding xdg-desktop-portal and it not being able to determine desktop portal version.

Part of configuration.nix file:

  # Portals
  xdg = {
    autostart.enable = true;
    mime.enable = true;
    menus.enable = true;
    icons.enable = true;
    sounds.enable = true;
    portal = {
      enable = true;
      wlr.enable = true;
      extraPortals = [
        pkgs.xdg-desktop-portal-wlr
        pkgs.xdg-desktop-portal-gtk
        pkgs.xdg-desktop-portal-hyprland
      ];
    };
  };

Is there a way I can tell Flatpak to use my system themes? Or fix my portals not functioning like normal (apparently).