Fontforge drops me into python?

Hi, I’ve added fontforge into home-manager config but surprisingly it seems to run python (despite fontforge being a bin program).

Possibly this might help:

{ fontforge }: fontforge.override { withPython =false; }

But I’m unclear where to stick it. (I could put it in the etc/nixos/configuration ?)

(It probably doesn’t help that I’ve not figured out the distinction between pkgs and programs in nix config.)

Any tips gratefully appreciated!

As there is no fontforge listed in home-managers options, how did you enable it?

Just by adding it to home.packages?

If yes, then doing the following should work:

home.packages = [
  (pkgs.fontforge.override { withPython = false; })

Of course you can also create a let binding, use an overlay, or combine all of these in a module.

If though you added it by other means, you need to tell us how.

Thanks - that works. It now drops me into some other prompt that isn’t python.

Hmm, fontforge on OSX is a gui… but on Linux it seems to be all about the scripting…

I think I’ll have to read up on how to start it in gui mode…

There seems to be a withGTK option available, have you checked if setting it true has the desired effect?

1 Like

There is fontforge-gtk attribute that does this.

Thanks a million - that’s great - I can now use it in all its glory and the mouse even clicks where the mouse pointer is (which is a big step up from OSX).

1 Like