Fprintd cannot detect Fingerpint reader

Howdy, I have a framework 13 and my goodix fingerprint reader cannot be seen by nixos. I had it working in a fedora install and have reinstalled nixos a few times always with zero luck, Any ideas?

sudo lshw | grep goodix -i -B 5 -A 5
                    serial: ----------------
                    capabilities: usb-2.00 usb
                    configuration: driver=usbhid maxpower=100mA speed=12Mbits/s
              *-usb:1 UNCLAIMED
                       description: Generic USB device
                       product: Goodix USB2.0 MISC
                       vendor: Goodix
                       physical id:  4
                       bus info: usb@1:4
                       version: 1.00
                       serial -------------------------
                       capabilities: usb-2.00
Impossible to enroll: GDBus.Error:net.reactivated.Fprint.Error.NoSuchDevice: No Device available

I solved it by disabling TOD. Remove the lines from your config:

services.fprintd.tod.enable = true;
services.fprintd.tod.driver = pkgs.libfprint-2-tod1-goodix;
1 Like

Thanks dude, this totally fixed it. So weird.