Frescobaldi under Hyprland - error on startup - Solved

Good morning! I have my system set up to use hyprland, and I am now slowly working through adding the applications I use on a regular basis. One of these is frescobaldi - a Qt application used for music manuscript.
When I start it, I get the following error message:

qt.qpa.plugin: Could not find the Qt platform plugin "wayland" in ""
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Looking through the issues on github, this appears to have been resolved with #76889, so I am not sure why I am seeing this problem.
Is anyone able to give me some pointers as to how to get this working? I don’t believe it is a hyprland issue - I mention this in case there is something I need to do under wayland compared with xorg.

EDIT: I have solved it: I needed to define the environment variable QT_QPA_PLATFORM=“wayland;xcb” - this uses xcb as fallback, satisfying the missing plugin shown above.


1 Like