Fresh NixOS installation boots into tty1 instead of X11

I tried to install the NixOS for the very first time. I successfully completed installation on my computer and have chosen Plasma Desktop and Colemak keyboard layout. When the computer restarted, the NixOS booted me into the console session.
I’ve checked the /etc/nixos/configuration.nix and it contained all options that I picked:

services.xsrever.enable = true;
services.xserver.displayManager.sddm.enable = true;
services.xserver.windowManager.plasma5.enable = true;

I checked that if I add applications to the config file (e.g. git), they are correctly installed, but X11/Plasma not loaded.

Then I tried to install NixOS in Hyper-V virtual machine, and to my surprise, the result was exactly the same - after instllation the VM would boot into the console session.

I have NVidia 4070 Ti GPU and in the past I was able to run several Linux distributives without any problems - Fedora, Ubuntu, Manjaro, no problems with Windows 10/11 either.

Is there something simple that I’m missing here?

If I try to start startx directly, I get the error message:

The program 'startx' is not in your PATH. You can make it available in an ephemeral shell by typing
nix-shell -p xorg.xinit

I am also having this issue :frowning:
same GPU

Did you figure this out ?