Getting "No route to host" with firewall disabled on NixOS

I’m experiencing a <urlopen error [Errno 113] No route to host> issue on NixOS and every hint on the Internet seems to indicate it’s a firewall issue. However, I have it disabled by default (via networking.firewall.enable = false;) so I am completely lost here.

It happens consistently when I run a Python script that updates Vim plugins in Nixpkgs but I also saw this error coming from other programs that make many HTTP requests in a short period of time. I made a screencast showing the issue:

I also tried two different Internet connections to discard a possible issue with my provider but the issue remains.

$ nix-shell -p nix-info --run "nix-info -m"
 - system: `"x86_64-linux"`
 - host os: `Linux 5.4.50, NixOS, 20.09pre233323.dc80d7bc4a2 (Nightingale)`
 - multi-user?: `yes`
 - sandbox: `yes`
 - version: `nix-env (Nix) 2.3.6`
 - channels(gvolpe): `"home-manager"`
 - channels(root): `"nixos-20.09pre233323.dc80d7bc4a2"`
 - nixpkgs: `/nix/var/nix/profiles/per-user/root/channels/nixos`

Anyone have any ideas of where I should be looking at? Thanks.

1 Like