Getting past "running udev" when installing in VirtualBox

I was having a problem today trying to install NixOS in a VirtualBox guest machine on a macOS host where it would never get past “running udev…”. After a bunch of futzing I finally got it to work so I figured I’d post this in case anyone else has the same issue. Also maybe someone might want to update the instructions at NixOS 23.11 manual | Nix & NixOS.

The symptoms were it would go through stage 1 and end up at “running udev…” and never print anything else after that.

What fixed it was going into the virtual machine settings, Display, Screen, and changing “Graphics Controller” to “VBoxVGA”. After doing this, it was able to get through the boot process and bring me to the root login.


I believe you can also boot with nomodeset kernel option to fix this issue.

That was one of the installer options, but I had no idea what that meant, nor did I even know that the installer was wedged due to a graphics controller issue until I tried changing the value.

1 Like

Thank you for the pointers to fix this issue. I was trying the same thing (grabbing the latest live nixos live iso and install nixos in a Virtualbox VM; virtualbox 6.0.6 on ubuntu derivate in my case). Either option allows me to proceed with booting from the live iso.

Thanks this solved my issue. May I add that it seems that you also need to set 32 MB for the video memory.
After getting it to work, I also figured that you can download the VM appliance and then just peek at the configuration values used there which will very likely guarantee to make a new VirtualBox instance to run with those parameters cloned.

I had the same issue.
Changing the graphicscontroller from VMSVGA to VBoxVGA solved the problem.