GitHub Copilot extension "requires VS Code 1.57+" when run on VS Code 1.71

See Github Copilot VS Code extension is not working with NixOS install of VS Code 1.71 - it is not recognised as a recent enough version for Github Copilot · Discussion #33392 · community · GitHub for somebody else’s post on GitHub’s discussion forum. They circumvented the problem by using flatpak, but I’m not sure why the copilot extension keeps seeing VSCode as outdated here.

Does anyone have any tips for debugging the vscode and copilot extension packages to see where the issue occurs?

Nevermind, I was able to figure it out. nixpkgs was pulling an old version of the extension. I just added the following to my config

++ pkgs.vscode-utils.extensionsFromVscodeMarketplace [
    name = "copilot";
    publisher = "GitHub";
    version = "1.46.6822";
    sha256 = "sha256-L71mC0190ZubqNVliu7es4SDsBTGVokePpcNupABI8Q=";

Thanks for reporting your fix. I’ve opened a nixpkgs PR with the suggested update: vscode-extensions.github.copilot: 1.7.4812 -> 1.46.6822 by Zimmi48 · Pull Request #192601 · NixOS/nixpkgs · GitHub