Gnome and GUI apps not saving information, maybe? I'm not sure

So, for some background, I’m new to Nix and NixOS and made a VM to get to know the system. After a few VMs (the final one being configured how I wanted and working) I made a slightly customized configuration.nix and installed the system on bare metal.

My user is perfectly fine, but the second user has an issue that I’m not entirely sure how to describe. Gnome extensions that i installed in configuration.nix are installed, but won’t enable (similar to this post) and apps that have a window to welcome the user, like Gnomes “take a tour” and nix-software-center’s pop up asking if all configs are in the default places or not just keep appearing as if every time I open them is the first time. I tried running su, chown brian ./ and chmod +w in his home directory thinking that maybe he just didn’t have permission for some reason, but that did nothing. This seems to only be GUI apps. When I launched the terminal, ZSH gave me it’s init script only once.

Thanks in advance for the help!

Here is my configuration.nix just in case there’s anything in there that will help:

`# Edit this configuration file to define what should be installed on

your system. Help is available in the configuration.nix(5) man page

and in the NixOS manual (accessible by running ‘nixos-help’).

{ config, pkgs, lib, … }:
nix-software-center = import (pkgs.fetchFromGitHub {
owner = “vlinkz”;
repo = “nix-software-center”;
rev = “0.1.2”;
sha256 = “xiqF1mP8wFubdsAQ1BmfjzCgOD3YZf7EGWl9i69FTls=”;
}) {};

imports =
[ # Include the results of the hardware scan.

Enable Experimental Features

nix.settings.experimental-features = [ “nix-command” “flakes” ];


boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;

networking.hostName = “mainframe”; # Define your hostname.

networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.

Configure network proxy if necessary

networking.proxy.default = “http://user:password@proxy:port/”;

networking.proxy.noProxy = “,localhost,internal.domain”;

Enable networking

networking.networkmanager.enable = true;

Set your time zone.

time.timeZone = “America/New_York”;

Select internationalisation properties.

i18n.defaultLocale = “en_US.UTF-8”;

i18n.extraLocaleSettings = {
LC_NAME = “en_US.UTF-8”;
LC_PAPER = “en_US.UTF-8”;
LC_TIME = “en_US.UTF-8”;

Enable the X11 windowing system.

services.xserver.enable = true;

Enable the GNOME Desktop Environment.

services.xserver.displayManager.gdm.enable = true;
services.xserver.desktopManager.gnome.enable = true;

Configure keymap in X11

services.xserver = {
layout = “us”;
xkbVariant = “alt-intl”;

Configure console keymap

console.keyMap = “dvorak”;

Enable CUPS to print documents.

services.printing.enable = true;

Enable sound with pipewire.

sound.enable = true;
hardware.pulseaudio.enable = false;
security.rtkit.enable = true;
services.pipewire = {
enable = true;
alsa.enable = true;
alsa.support32Bit = true;
pulse.enable = true;
# If you want to use JACK applications, uncomment this
#jack.enable = true;

# use the example session manager (no others are packaged yet so this is enabled by default,
# no need to redefine it in your config for now)
#media-session.enable = true;


Enable touchpad support (enabled default in most desktopManager).

services.xserver.libinput.enable = true;

#Enable Zsh
programs.zsh.enable = true;

virtualisation.docker.enable = true;

Define a user account. Don’t forget to set a password with ‘passwd’.

users.users.joshua = {
isNormalUser = true;
description = “Joshua”;
extraGroups = [ “networkmanager” “wheel” “docker” ];
openssh.authorizedKeys.keys = [
packages = with pkgs; [

shell = pkgs.zsh;


users.users.brian = {
isNormalUser = true;
description = “Brian”;
extraGroups = [ “networkmanager” ];
packages = with pkgs; [

shell = pkgs.zsh;


Allow unfree packages

nixpkgs.config.allowUnfree = true;

List packages installed in system profile. To search, run:

$ nix search wget

environment.systemPackages = with pkgs; [

Some programs need SUID wrappers, can be configured further or are

started in user sessions. = true;

programs.gnupg.agent = {

enable = true;

enableSSHSupport = true;


List services that you want to enable:

Enable the OpenSSH daemon.

services.openssh = {
  enable = true;
  # require public key authentication for better security
  settings.PasswordAuthentication = false;
  settings.KbdInteractiveAuthentication = false;

Open ports in the firewall.

networking.firewall.allowedTCPPorts = [ … ];

networking.firewall.allowedUDPPorts = [ … ];

Or disable the firewall altogether.

networking.firewall.enable = false;

This value determines the NixOS release from which the default

settings for stateful data, like file locations and database versions

on your system were taken. It‘s perfectly fine and recommended to leave

this value at the release version of the first install of this system.

Before changing this value read the documentation for this option

(e.g. man configuration.nix or on NixOS Search).

system.stateVersion = “23.05”; # Did you read the comment?


Tomorrow, I’ll try removing his account from the Nix config, rebuild the system, add his account again and rebuild to see if that fixes it. He has nothing stored in his home so I’ll delete that as well before rebuilding with his account added once again.