GNOME: Dark Mode not working correctly

Im just using NixOS some days and wondering why some applications wont go dark.
im coming from the debian community, and there, everything worked fine.

some programs they’re not going dark are:

  • dia
  • virt-manager
  • geary

some inforamtion about my system:

  • NixOS-version: 23.11
  • Gnome-version: 45.5

would be very happy about awnsers.

Maybe just a workaround, but does setting GTK_THEME=Adwaita:dark work?


$ export GTK_THEME=Adwaita:dark
$ geary

If so, you can set it globally using

environment.variables.GTK_THEME = "Adwaita:dark";

If you use home-manager, I found having

gtk = {
  enable = true;
  gtk3.extraConfig.gtk-application-prefer-dark-theme = 1;

helped at some point and I’ve been too lazy to test if I can take it out since about a year ago.

Geary isn’t ported to GTK4 yet, but that might change in the foreseeable future. There’s also an old Merge Request for Dark Mode.

As a workaround (non-Nix-way) you can also use GNOME Tweaks to set the appearance for “legacy applications” to “Adwaita-dark”.

I ran into the same issue and this is how I fixed it:

# Home Manager solution
home.packages = with pkgs; [
dconf.settings = {
    "org/gnome/desktop/interface" = {
      color-scheme = "prefer-dark";
      gtk-theme = "adw-gtk3-dark";

I set a custom theme to make GTK2/3 applications look like GTK4 ones, but it should work with Adwaita-dark as well, like other people mentioned.