GNOME dynamic workspaces not working

Hello flolks!

After awhile loving Nix and NixOS on servers, I took the leap and installed it in my laptop.

One nasty issue I’m noticing is that, although I configured GNOME with dynamic workspaces, it doesn’t seem to work.

It always starts with a fixed amount of 2 workspaces. If I flip that switch to fixed number and back to dynamic, then I have 4 fixed. But never dynamic.

What’s happening? How do I fix it?

My OS + home-manager flake:

As far as I know, this is how dynamic workspaces work ('*' means last workspace):

  • You start with 2 workspaces: W1 > W2*

  • Put a window in the first one, no new workspaces are added: W1 > W2*

  • Put a window in the last one, a new empty workspace gets created after it: W1 > W2 > W3*

  • Keep adding windows to the last one and workspaces will be created after: W1 > W2 > W3 > W4*

  • If a workspace becomes empty and it’s not the last one, all workspaces will be shifted so that only the last one is empty. From the previous example, let’s say W2 is now empty, so: W1 > W2 > W3*.
    (W3W2 and W4W3)

Is this not working for you or do you expect something different?

1 Like

I can confirm, this is the expected behavior when dynamic workspaces are on.

1 Like

No, for me it’s behaving like if I just had a static amount of workspaces.

I’m used to the flow you say from Fedora, but since I installed NixOS I lost that and I can’t figure out how to recover the dynamic workspaces feature.

I’ll reinstall and see if that helps.

1 Like

Before re-installing, you should check and see if you have the Auto Move windows extension enabled. If yes, then you should disable it as some people have reported that it was the cause of this issue.

Yes I have it. I’ll check removing it and report. Thanks!

1 Like

Removing that extension fixed it, thanks!

1 Like