Gnome XRDP color profile error

I’d like to use Gnome over XRDP.

Currently I’m only able to run i3 or xfce as normal. When I use gnome I can attach the session but then I’ll get an error stating “You need to authenticate to set the color profile” but no matter how often I dismiss it or provide a password: It asks again, and again and again.

The relevant config looks like this:

  services.gnome.gnome-remote-desktop.enable = true;
  services.xrdp = {
    enable = true;
    #defaultWindowManager = "${pkgs.gnome.gnome-session}/bin/gnome-session";
    #defaultWindowManager = "${pkgs.xfce}/bin/xfce-session";
    defaultWindowManager = "${pkgs.i3-gaps}/bin/i3";

Is there any other service I need to activate in order for this to work as expected?

1 Like

Did you ever get this working? I want to use gnome over xrdp too. There’s not much written about it, either here, or /r/nixos, or the nixos docs or wiki, even though gnome is nixos’s default desktop.

PS - your example is missing the services.xrdp.openfirewall line.

If I remember correctly it worked one day when I dismissed the dialog multiple times (like around 10 times in a row…). It should work correctly with the line you’re seeing above. But aside from that it didn’t work great over RDP (slow/sluggish desktop feel). I think the next time I’d rather use VNC.

I would imagine that the openfirewall line was not necessary two years ago, since I’m pretty sure I just copy and pasted the contents of my config verbatim ^^

Did not have an issue with color profile but this is my snippets to get GNOME working over xrdp, using remmina as a viewer from my environment.systemPackages.

# Gnome RD services 
  services.gnome.gnome-remote-desktop.enable = true; 
  services.xrdp.enable = true;
  services.xrdp.defaultWindowManager = "gnome-session";
  services.xrdp.openFirewall = true;

# Firewall module
 networking.firewall = {
   enable = true;
    #trustedInterfaces = [ ];
    allowedUDPPorts = [ 3389 22 80  ];
    allowedTCPPorts = [  22 80 ]; };
1 Like