Help installing wifi drivers

I recently acquired a TP-Link Archer T3U wifi adapter, and it turns out I don’t have the right drivers to use it (when I run nmcli d, the device is not listed). Does anyone with experience with drivers know how I might be able to install the necessary drivers on NixOS?

For reference, here’s what the output of sudo dmesg says about the adapter:

[27047.133985] usb 1-1: new high-speed USB device number 6 using xhci_hcd
[27047.260694] usb 1-1: New USB device found, idVendor=2357, idProduct=012d, bcdDevice= 2.10
[27047.260700] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[27047.260703] usb 1-1: Product: 802.11ac NIC
[27047.260706] usb 1-1: Manufacturer: Realtek
[27047.260709] usb 1-1: SerialNumber: 123456

I did the following for my DLink.

	  boot.extraModulePackages = [ config.boot.kernelPackages.rtl8192eu ];

Bit of backstory:

Tried D-Link adapter for a few hours. Did’t work (I believe it was listed by nmcli). Added the above line. Now works one out of two days. So I’m not sure if this line changed anything but see if a similar line can help you. (After adding your own driver in place of rtl8192eu )

@ Bleu-Box

I have the same device. Were you able to make it work?

Fwiw, now it works all the time.

Unfortunately I couldn’t figure it out and had to return the adapter :/. But thankfully I’ve got a long ethernet cable now.

I was able to find the chipset: rtl8822bu.
The driver was not working, but as soon as I added the id for this device it started to work.

Here you find my push request: https://github.com/ulli-kroll/rtl8822bu/pull/15

Or you can clone my patched repository: https://github.com/nscendoni/rtl8822bu

I tested it with Fedora 31.

Regards

Nicola

1 Like