Help with LD_LIBRARY_PATH when running mongodb in meteor package

I have a problem with the meteor package in nixpkgs, and I posted an issue a while ago, but seems the maintainers of the package are not active anymore - I figured out how to fix it by manually setting LD_LIBRARY_PATH, but I’m not sure how to do this the nix way… Can someone help?

The problem and workaround are well described in the issue