Help with OpenBB Investment Research Platform & Docker Install

I would like to install the latest version of OpenBB, which is an open source project that is similar to Bloomberg Terminal in many ways, and remove/cleanup my old container of it. There may be a permission issue which may or may not be NixOS related (detailed below). I should say I’m attempting to learn Docker, but am making slow progress. I’ve also heard there is a way to have NixOS manage containers, but I’m not sure how to do so or if it would help in this instance.

Quite a few months ago I was able to use Docker to install OpenBB on NixOS. I currently have a container working of an older version (v1.6.0) of OpenBB working, which I run with this command, per their old instructions:

docker run -it --rm

and it opens in my terminal and works as it is supposed to, albeit it is out of date and the internal update command does not work.

I also have “docker” in extraGroups for my user as so:

    extraGroups = [ "docker" "networkmanager" "wheel" ];

I just left everything as is on my system and attempted to run the new instructions, per:

When I installed the old version of OpenBB I created a director ~/Software/OpenBB and downloaded the docker-compose.yaml to this directory. So I did the same thing for the newest version via Danglewood’s (from their Discord) suggestion:

curl -o docker-compose.yaml

I should say, I don’t fully understand how/where Docker installs containers, but I know that I can docker images which shows that I now have

01:31 PM zonsopkomst@weda $
(~)>>>docker images
REPOSITORY                                     TAG       IMAGE ID       CREATED        SIZE   2.5.1     a15a7fa3376e   12 days ago    7.48GB   latest    e8ac478cf581   7 months ago   2.54GB

I tried Danglewood’s suggestions and ran docker compose run openbb and get the following:

01:34 PM zonsopkomst@weda $
(~/Software/OpenBB)>>>docker compose run openbb
Traceback (most recent call last):
  File "/home/python/", line 5, in <module>
    from openbb_terminal.terminal_helper import is_auth_enabled
  File "/home/python/openbb_terminal/", line 18, in <module>
    from openbb_terminal import (
  File "/home/python/openbb_terminal/", line 17, in <module>
  File "/home/python/openbb_terminal/core/config/", line 75, in init_userdata
  File "/home/python/openbb_terminal/core/config/", line 27, in create_paths
  File "/usr/local/lib/python3.10/", line 1175, in mkdir
    self._accessor.mkdir(self, mode)
PermissionError: [Errno 13] Permission denied: '/home/python/OpenBBUserData/styles'

He was saying there was a permission issue (last line above), but I think my user already has permission from extraGroups (above) since it works with the older version, but I could be wrong. Maybe a path issue due to the way nix installs packages?

So my old container did not update. The next attempt was running the latest instructions from the link above from their site:

docker run --rm -it \
  -v ~/.openbb_terminal/:/home/python/.openbb_terminal \
  -v ~/OpenBBUserData:/home/python/OpenBBUserData \

and the container does not run. I’m not in front of my PC right now, but I think it said the container or image was not found. I will gladly add the output or any other requested diagnostics a little later if it would help.

And that’s where I left off.

Here is the conversation I started on Discord for reference:

Any help is appreciated!

Can you check ~/OpenBBUserData permissions ?
The docker-compose.yaml file contains:

    - ~/OpenBBUserData:/home/python/OpenBBUserData
    - ~/.openbb_terminal:/home/python/.openbb_terminal

~/OpenBBUserData and ~/.openbb_terminal are folders (or files) that will be mounted from your local machine into a docker container. If the folders don’t exist, docker will create them with root ownership.

My permissions after I run docker compose run openbb:

drwxr-xr-x 1 root  root       0 03-15 20:50 .openbb_terminal
drwxr-xr-x 1 root  root       0 03-15 20:50 OpenBBUserData

Change the owner of ~/OpenBBUserData and .openbb_terminal to your user, then docker compose should work.

Thank you @rkotkiewicz! I followed your directions:

zonsopkomst@weda $
(~)>>>sudo chown -R zonsopkomst:docker .openbb_terminal

zonsopkomst@weda $
(~)>>>sudo chown -R zonsopkomst:docker OpenBBUserData

zonsopkomst@weda $
(~)>>>cd /home/zonsopkomst/Software/OpenBB/

zonsopkomst@weda $
(~)>>>docker compose run openbb

and upon executing the finale command, OpenBB works.

I also removed the older image:

07:10 AM zonsopkomst@weda $
(~)>>>docker images
REPOSITORY                                     TAG       IMAGE ID       CREATED        SIZE   2.5.1     a15a7fa3376e   13 days ago    7.48GB   latest    e8ac478cf581   7 months ago   2.54GB

07:10 AM zonsopkomst@weda $
(~)>>>docker rmi e8ac478cf581
Deleted: sha256:e8ac478cf581b20e3a57982032e05e8a087888ee9e0a4229e6d1735ccdeb87f8
Deleted: sha256:99f7b820e3d8e610c83e762bbc7109e782b7e7ca64e90b9769b52b6ce15d2769
Deleted: sha256:4b1fa85a79b3a6274b2da970dbbf45779eef90c1e17f5472dd5de3d96c413b63
Deleted: sha256:1927d65a2555e3545bcb10f66c135655d7e992d1291b2b19d7225d76bd2fe308
Deleted: sha256:ea124c6aa69ff611099e2954d7a92388a6894539d93a23a51363ceb171e39bd4
Deleted: sha256:6bdd676d2e976a1168d89fd9aa3cc74ee0066e8f86def62469aa83cb1a40410b
Deleted: sha256:35fc4aa67974112af940b838cfc3b9608b065ec3267df5a5e1b7799d2c6e288b
Deleted: sha256:f9cb4a6e1bd54d120380b66c5c0dbef753e9430ec4833a1e30c0f002c0f63f44
Deleted: sha256:a1efc3b9bb00029b2564786d07e34e1787e62f2f6607babc81f1f2ff57645010
Deleted: sha256:6086e22fd45e049c45f0b453fe5882283a3ff4fcb406414e98f487675caae049
Deleted: sha256:1b2282b9331a600223ce1599f59c40c6e449b6d3ccb04574a9d5ed5b8a1103e8
Deleted: sha256:735956b91a18480450076b4e4a1f403cfe0c0f1dc7bf065341c2446fa045347d

07:10 AM zonsopkomst@weda $
(~)>>>docker images
REPOSITORY                                     TAG       IMAGE ID       CREATED       SIZE   2.5.1     a15a7fa3376e   13 days ago   7.48GB