Home-manager and fzf keybindings

How can I get fzf keybindings to work in a bash shell?

From what I understand, this should be enough, but it’s not working:

home-manager.users.myname = {
  home.stateVersion = "23.11";
  programs.fzf.enable = true;

If I say in a terminal source "$(fzf-share)/key-bindings.bash" the keybindings work. Not so, if I add it to programs.bash.initExtra.

I think you also need to enable bash integration via programs.bash.enable = true;, as it adds the code to initExtra but does not enable bash itself https://github.com/nix-community/home-manager/blob/4ee704cb13a5a7645436f400b9acc89a67b9c08a/modules/programs/fzf.nix#L176

Thanks, that did the trick indeed!