Home Manager: Collision between `fluffychat` and `yubioath-flutter`

Hi,

I’ve been trying to install fluffychat and yubioath-flutter together through home-manager, but it results in following collision when rebuilding my configuration:

$ sudo nixos-rebuild switch
...
building '/nix/store/fvygcd7szpgda6q1gdlz3vb7i8s8p9kc-home-manager-path.drv'...
error: collision between `/nix/store/dy862i12nxxjvjj046zsmyr41whwp06m-fluffychat-linux-1.20.0/app/data/flutter_assets/version.json' and `/nix/store/9w1f41gml5zs0cn07nsvrbda6z0zcwl4-yubioath-flutter-6.4.0/app/data/flutter_assets/version.json'
error: builder for '/nix/store/fvygcd7szpgda6q1gdlz3vb7i8s8p9kc-home-manager-path.drv' failed with exit code 25
error: 1 dependencies of derivation '/nix/store/czx3wzsxad52kzf0p19sb6578554fng3-home-manager-generation.drv' failed to build
error: 1 dependencies of derivation '/nix/store/iy6zjh2h1r9laf9dy7si7ndfsh9z84mh-user-environment.drv' failed to build
error: 1 dependencies of derivation '/nix/store/8zx7g518jcx6rxpnw89hjzj6iwmhdc7k-etc.drv' failed to build
error: 1 dependencies of derivation '/nix/store/0f3qlwm1d10fznzbkdqmbkdjf5hpriha-nixos-system-nixin-24.11pre639882.b60ebf54c155.drv' failed to build

I also noticed that both these packages install fine together when not using home-manager.

Any help if I can get them working together with home-manager though? Thanks.

1 Like

This seems to be an ongoing issue:

Using users.users.<name>.packages should work for now, as it will give the same result as using home.packages - i.e. only install packages for your current user.

1 Like