Home Manager Not Consistently Pullng the Latest Unstable Packages

I am using the unstable channel and latest home manager. Here is the beginning of my flake:

inputs = {
    nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";

    home-manager.url = "github:nix-community/home-manager/master";
    home-manager.inputs.nixpkgs.follows = "nixpkgs";

However, multiple applications are not using the latest packages in the unstable channel based on the differences between what is installed and what the online Package Search says is the latest version.
Some packages are the most up to date, for example Alacritty:

▶ nix search nixpkgs alacritty
* legacyPackages.x86_64-linux.alacritty (0.13.1)

Some packages are a recent but not latest version according to the online package search, such as VSCode (1.85.1 vs 1.86):

▶ nix search nixpkgs vscode-with-extensions
* legacyPackages.x86_64-linux.vscode-with-extensions (1.85.1)

And some packages are the ones from the 23.05 channel, like google-chrome (120.0.6099.224 vs 121.0.6167.139):

▶ nix search nixpkgs google-chrome
* legacyPackages.x86_64-linux.google-chrome (120.0.6099.224)

I am running hyprland on an x86_64 linux system. Is there something I a failing to do to ensure that I get the latest packages consistently?



It might be a basic question, but how are you running your updates?

I update the channels, although I am unclear if that is really necessary with flakes. I do it out of habit. Then I run:
sudo nixos-rebuild switch --flake ...
home-manager switch --flake ...

Is there a different approach, I should be taking?

I ran into a similar issue lately, and I should have been going to where my flake.lock file is, and simply running

nix flake update


nixos-rebuild switch --use-remote-sudo  --flake <path-to-flake>

I think that was the issue. I had not been consistently running nix flake update

Thank you!

1 Like