How can I set up silent boot?

Hi,

I would like to know how to set up “silent boot”.

I’ve tried it with
boot.kernelParams = [ "quiet" ] in my hardware-configuration.nix.

I can see that in the generated /boot/grub/grub.cfg quiet was added like this:
...f142e001b/init quiet loglevel=4
but the boot output is still verbose. I think I had the same problem on an other distro and resolved it with changing the parameter order. Is this the same problem and if it is, how can I remove loglevel to add it with boot.kernelParams?

Thanks