How do I set up WIFI with KDE Plasma

How can I set up KDE Plasma with WIFI? Thanks for the help. Usually there is a WIFI icon in the taskbar tray.
However no icon in the tray. Appreciate the help.

https://nixos.org/manual/nixos/stable/#sec-networkmanager

1 Like

Previously, I tried the settings from the manual and the boot process locked up my system. I had to shutdown my laptop and did another boot to get back to the prompt. Can someone provide their configuration.nix settings.
Thanks.

Here is my configuration.nix:

{ config, pkgs, … }:

{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
];

Use the systemd-boot EFI boot loader.

boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;

networking.hostName = “nixos”; # Define your hostname.
networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.

networking.useDHCP = false;
networking.interfaces.enp0s31f6.useDHCP = true;
networking.interfaces.wlp3s0.useDHCP = true;

networking.networkmanager.unmanaged = [
“*” “except:type:wwan” “except:type:gsm”
];

services.xserver.enable = true;

services.xserver.displayManager.sddm.enable = true;
services.xserver.desktopManager.plasma5.enable = true;

Recently I was helping a friend with a flaky wifi connection and discovered that iwd worked much better than wpa_supplicant. I started using iwd myself after that.

This is the only networking.* stuff in my config at the moment:

networking.networkmanager.enable = true;
networking.wireless.iwd.enable = true;
networking.networkmanager.wifi.backend = "iwd";

PROBLEM SOLVED

Great buovjaga! WIFI now works in Plasma5. I have been working this problem for two weeks and could not find a solution. I was ready to give up till I received your message. Many thanks for helping me out.

I tries this out on a whim, and while things work, there are gaps. Particularly, hidden networks are not connected to. I dogged around and added Hidden=true in config, but still result is same. If anyone faced this and found a solution, please lmk.

Maybe you could start a new topic to draw attention to it. Possibly the wiki article could be expanded.

Done!

1 Like
Hosted by Flying Circus.