How do I uninstall vscodium installed via nix-darwin?

I removed it from my darwin configuration file and rebuilt it.
It removes the codium binary from the path and removes the Application from the /Applications/Nix Apps folder.
But I know this isn’t over because vscodium still shows up in Launchpad. And when I click it, it actually opens. Meaning, the binary is still there somewhere.

I found out that these are still present in the nix store:

├── Applications
│   └──
└── bin
    └── codium -> ../Applications/

I wish to remove this but I worry about blindly deleting the nix/store entry.

nix store delete /nix/store/4ghl639j3kayp4r6j888waiwf87fff5i-vscodium- does not work because this path is still used by nix somewhere.

nix-store --query --roots /nix/store/4ghl639j3kayp4r6j888waiwf87fff5i-vscodium- gives me:

/nix/var/nix/profiles/system-13-link -> /nix/store/xy8xn7p7d93d82az9k3bfdr1slfbzmk5-darwin-system-23.11pre527787.e12483116b3b+darwin4
/nix/var/nix/profiles/system-3-link -> /nix/store/931147anpckm0r7cprhc6p1j8lq9qqdr-darwin-system-23.11pre527787.e12483116b3b+darwin4

Can someone help me with cleaning this up?

Nix generally allows constant-time rollbacks to earlier system states. Try running a garbage collect (nix-collect-garbage -d, which will delete all previous generations of configuration).

It cleared some stuff but not vscodium.
nix store delete still gave the same error as above.
The nix-store --query --roots response is still the same.

Sorry, I made the usual classic blunder here. sudo nix-collect-garbage -d.

Haha thanks, this deleted it. The launchpad entry I had to hold via the mouse and delete but I wasn’t able to before.