How to disable Konsole main toolbar & session toolbar?


I noticed that Konsole has a new toolbar section:

which, I had never seen before.

By right clicking on the toolbar, you can select whether you want to disable/hide them;
Main Toolbar
Session Toolbar

Now my question is how do you consistently disable them by default? I tried Settings → Configure Konsole but I didn’t see such settings for these two toolbars. I would like to write in konsolerc some settings so that I version control it but couldn’t find commands for those toolbars.

From this and this threads I can see that there should be an option in Settings called “Toolbar shown” or something like that, but I can’t see this option in my Settings menu. Can someone please help? Thanks!

Right click a little to the right of the “Help” menu?

Hi. Like I said in my original post, doing so would only disable/hide the toolbars. If you exit Konsole and re-open it the toolbars would still be there. I’m wondering if there’s a way to just disable them by default. I checked the Settings but there are no such settings targeting these two toolbars.

Ah, I missed that :blush: For me the settings persists. No idea what’s wrong in your case, I’m afraid.

EDIT: though I really only use the desktop stuff from stable NixOS 21.05.

I have a similar problem – each time I try to change the default profile from “Default” (which cannot be edited) to a user-defined one, ~/.config/konsolerc does not reflect the change. And if I edit it manually, my edits are discarded and it resumes its earlier value as soon as I open another instance of Konsole.

It also seems noteworthy that konsolerc does not actually define the DefaultProfile. It includes the following line:


with nothing on the RHS of the equal sign.

I’ve never tried editing konsolerc, and always configured via GUI. The menu-bar just worked for me. Toolbars Shown submenu is under Settings:

Usually I keep the menu-bar disabled as well (C-S-m).

I configured a separate profile from GUI as well and it has stuck across 2 major plasma updates so far.

Rebooting seemed to solve the problem. Now the line in konsolerc reads DefaultProfile=Profile 1.profile. I may have saved it that way before rebooting; I can’t remember.