How to driver setup mac pro 2013 (firepro d500) and intel HD Graphics 520 for wayland(sway)?


I am trying to use Wayland with Sway on an AMDGPU-based FirePro D500, but it’s not working well.

Neither the amdgpu driver nor the amdgpu-pro driver seems to work. Only X11 does.

My boot kernel parameters are as follows:

# for Southern Islands (SI, i.e., GCN 1) cards
"radeon.si_support=0" "amdgpu.si_support=1"

I’ve tried using the Vulkan driver and also reverted back to the previous mesa_drivers. From what I’ve heard, the older FirePro graphics cards don’t support recent Vulkan drivers.

So, I changed from




and tried running it, but

I still get the following error:

00:00:00.060 [wlr] [types/wlr_drm_lease_v1.c:715] No DRM backend supplied, failed to create wlr_drm_lease_v1_manager

Does this mean that there isn’t a fully compatible driver available yet, making it impossible to use Wayland?

If anyone who has faced similar issues has any insights, please let me know."


As an additional point, I’m also unable to get Wayland Sway working with an

Intel(R) HD Graphics 520 (SKL GT2)

graphics card. I’d like to get the driver working for this as well.

I haven’t tried Sway (maybe I can tomorrow), but I’ve had GNOME on Wayland working with these settings (and the same computer as yours):

    boot = {
      initrd.availableKernelModules = [ "ehci_pci" "nvme" "xhci_pci" "usbhid" "usb_storage" "sd_mod" ];
      initrd.kernelModules = [ "amdgpu" ]; #
      kernelModules = [ "kvm-intel" "applesmc" "i915" "psmouse" "wl" ]; # kvm-intel is for libvirtd; psmouse is for my Bosto trackpad; wl was suggested by nixos-generate-config
      extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
      kernelParams = [ "i915.enable_rc6=7" "intel_pstate=active" "acpi_mask_gpe=0x15" "radeon.si_support=0" "amdgpu.si_support=1"]; # Enables RC6, RC6p and RC6pp sleep states, and see for "acpi_mask_gpe=0x15", and see
1 Like

Those settings work for me with Sway as well \o/

1 Like

Could you possibly tell me which Apple modules have been added here, or the list of


you’ve chosen from this link?

On my other PC, both Wayland Sway and Hyprland work fine, even with the same amdgpu y,.y


This sentence is padding because Discourse won’t accept an answer less than 20 characters long.

1 Like

The issue with Intel graphics cards was caused by not linking one’s own sway setup file, namely “~/.config/sway/config”. A bit perplexing is the fact that the nix compiler is not stable. There’s a problem where configuration files that should be created in xdg (~/.config/) or the homeDirectory during nixos flake + home-manager setup are not properly generated. Therefore, it’s necessary to directly find and execute blah blah-home-manager-generation/activate in /nix/store/.

After installing nix build, the total build of nixos, it’s frustrating because of the backend tasks that don’t run properly. Obviously, it’s annoying because you can never know when an error might occur due to issues in linking these config files, so there’s a need to constantly check and rebuild.

I wish nixos would directly handle the xdg config and home-file config of home-manager.

I’ve also succeeded in getting Sway to run on my Mac Pro 2013. The issue is that I have to manually start Sway on this particular Mac Pro. It doesn’t start automatically, which is kind of funny haha. I can’t understand why it starts automatically on other computers with the same settings. I had to forcibly place a config file under /etc/sway/. I’m not sure why, but there’s definitely an issue with the home-manager configuration update I mentioned earlier.
Since I need to keep checking if the configurations under ~/.config/ and the links to the home directory settings are being properly created through rebuilding…
I guess I should just set it up forcibly, without going through Home-manager this time, using the mkdir command huh.k;

Ah, when will I find the time to look into this again haha. Thanks, you’ve really been a help.
Have a great Friday~*

1 Like

As a side note, the problem with home-manager turned out to be that I need to delete the ~/.config directory before running a nix system build and then have it recreated every time during the build. This means I won’t have to rewrite the entire script. Still, I haven’t figured out the issue with not being able to automatically log in to Sway directly on boot.