How to enable ascii symbols input with keyboard?


Would someone know how to enable special ASCII characters with the keyboard? I mean like this (Insert ASCII or Unicode Latin-based symbols and characters - Microsoft Support)

I use this functionality all the time for accents, but for some reason when I press “Alt” key it does not seem to be waiting for any code to be written and it just outputs whatever key you pressed (apart from ALT)

I am not sure if it’s a problem with my keyboard in NixOs or more people has the same issue (I could not find any topic about it).

This is the code I have for my keyboard configuration:

  # Configure keymap in X11
  services.xserver.xkb = {
    layout = "us";
    variant = "";

  console.keyMap = "us";

Keyboard: Razer huntsman analog v2. US layout.

This is also my first post. Thanks a lot to the developers for such a great project and to the community.


if you enable ibus (i18n.inputMethod.enabled = "ibus";) then you get two key bindings (I can’t tell you the default ones, I customized them):

  • one to type characters and emojis by name, for me typing super+; then univ (for universal quantifier) then space then enter types . If you type space several times a graphical popup enables you to choose visually
  • one to type characters by code point

with the default ibus interface (not the one of gnome, presumably), this can be customized here:

1 Like

What you’re asking about is called Unicode input. Where on Windows you’d press Alt+10052, in GNOME the analogous technique is:

  1. Ctrl+Shift+U
  2. 2744 (the same number in hexadecimal)
  3. Space or Enter


I thought there was a way to do by default ALT + numpad code, but as you guys say unicode input should be used.
It’s working the way you suggested @_Andrew.

My input method seems to be by default ibus.

Thanks both