How to get compiz to run with x2go?

since everything is a bit different with nixos, I’m having trouble connecting with x2go to a nixos-container.

The specific use case is that I want to get Universal Media Server (ums) to work which uses Java’s PERPIXEL_TRANSLUCENT which is not available if I use x2go with icewm. My guess is that hardware acceleration is not available.

I tried to connect using x2go w/ gnome, but that just crashes saying it cannot start /usr/bin/gnome-session.

now I have given my nixos container permission to access:

      "/tmp/.X11-unix" = {
        hostPath = "/tmp/.X11-unix";
        isReadOnly = false;
      "/dev/dri" = {
        hostPath = "/dev/dri";
        isReadOnly = false;
      "/dev/shm" = {
        hostPath = "/dev/shm";
        isReadOnly = false;

I don’t exactly know what the problem is. Maybe hardware acceleration in the container isn’t working and thus not activated. Maybe I need to start compiz for my x2go session. How would I do that?

I do prefer gnome, but in the end I just want to get ums running properly. I tried xpra, which works for a few dialog boxes, but then stops rendering properly at the point where the flash-screen appears.

Any suggestions?