How to get xkb options working with Xfce?

Trying to get Dvorak working via configuration.nix but am not making any progress. Any ideas?

The configuration.nix file contained this:

services.xserver = {
layout = “us”;
xkbVariant = “dvorak,”;
xkbOptions = “grp:win_space_toggle”;

It did not have any effect from what I can see, so I did some cursory research, and added these packages:

environment.systemPackages = with pkgs; [

Still not able to switch the keyboard layout with Win+Space.

I thought it might try this with i3 and it isn’t working either.

Tried the following (because I am using home-manager), but it didn’t work either: Need Help xkbOptions is not working

According to the arch wiki

The number of XkbLayout s should match that of the XkbVariant s — if you want to switch solely between different variants, then duplicate the layout accordingly (e.g. de,de ).

so maybe try layout = "us,us"; ?

Alternatively this is a functionality that you can get by ibus I think: i18n.inputMethod.enabled = "ibus".

1 Like